<!DOCTYPE HTML>
<html lang="en">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>Another small fix for memory cleanup &middot; Anna VS the A.I.maze update for 22 October 2022 · SteamDB</title>
<link rel="stylesheet" integrity="sha512-byv6IWW9bEJ+oEh8g8VgGTK0ywqWF04zAFHF/551RG/LgmmetvRqAwhduF7x9IDjA0sqGqTiJmda6zwT6NE20w==" href="/static/css/headcrab.css?v=6f2bfa2165bd6c42"><link rel="stylesheet" integrity="sha512-QYz7E03zanEdUfcJI2XOHtix0APQ1tBpIaP0K8nkTDFSuxR4y1B1uwQiOvh98xPBPtHVxbcRfpTULyp1tDTrlw==" href="/static/css/forum.css?v=418cfb134df36a71">
<link rel="alternate" type="application/rss+xml" title="SteamDB Builds for app 1957860" href="https://steamdb.info/api/PatchnotesRSS/?appid=1957860">
<link rel="alternate" type="application/rss+xml" title="SteamDB Blog" href="https://steamdb.info/api/BlogRSS/">
<link rel="canonical" href="https://steamdb.info/patchnotes/9775839/">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@SteamDB">
<meta property="og:type" content="website">
<meta property="og:site_name" content="SteamDB">
<meta property="og:title" content="Another small fix for memory cleanup &middot; Anna VS the A.I.maze update for 22 October 2022">
<meta name="description" content="Just bug fix of memory cleanup&hellip;">
<meta property="og:description" content="Just bug fix of memory cleanup&hellip;">
<meta property="og:image" content="https://steamdb.info/patchnotes/9775839.png?_=1666413966">
<meta name="theme-color" content="#64ACFF">
<meta name="application-name" content="SteamDB">
<meta name="apple-mobile-web-app-title" content="SteamDB">
<link rel="manifest" href="/steamdb.webmanifest">
<link rel="icon" type="image/png" href="/static/logos/32px.png">
<link rel="icon" type="image/svg+xml" href="/static/logos/vector_prefers_schema.svg">
<link rel="apple-touch-icon" sizes="180x180" href="/static/logos/512px_maskable.png">
<link rel="mask-icon" href="/static/logos/vector_16px.svg" color="#000000">
<link rel="search" type="application/opensearchdescription+xml" href="/opensearch.xml" title="SteamDB">
<link rel="preconnect" href="https://cdn.cloudflare.steamstatic.com/">
</head>
<body class="page-patchnotes" itemscope itemtype="http://schema.org/WebSite" data-steam-cdn="https://cdn.cloudflare.steamstatic.com/">
<a class="skip-main" href="#main" id="js-skip-main">Skip to content</a>
<div class="header" role="banner">
<div class="header-menu-button-container">
<button type="button" class="header-menu-button" id="js-header-hamburger" accesskey="m" aria-label="Toggle menu"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-three-bars" aria-hidden="true"><path fill-rule="evenodd" d="M1 2.75A.75.75 0 011.75 2h12.5a.75.75 0 110 1.5H1.75A.75.75 0 011 2.75zm0 5A.75.75 0 011.75 7h12.5a.75.75 0 110 1.5H1.75A.75.75 0 011 7.75zM1.75 12a.75.75 0 100 1.5h12.5a.75.75 0 100-1.5H1.75z"></path></svg> <span>Menu</span></button>
</div>
<div class="header-navbar">
<a href="/" class="header-brand" itemprop="url" aria-label="Homepage"><svg version="1.1" width="30" height="30" viewBox="0 0 128 128" class="octicon octicon-steamdb" aria-hidden="true"><path fill-rule="evenodd" d="M63.9 0C30.5 0 3.1 11.9.1 27.1l35.6 6.7c2.9-.9 6.2-1.3 9.6-1.3l16.7-10c-.2-2.5 1.3-5.1 4.7-7.2 4.8-3.1 12.3-4.8 19.9-4.8 5.2-.1 10.5.7 15 2.2 11.2 3.8 13.7 11.1 5.7 16.3-5.1 3.3-13.3 5-21.4 4.8l-22 7.9c-.2 1.6-1.3 3.1-3.4 4.5-5.9 3.8-17.4 4.7-25.6 1.9-3.6-1.2-6-3-7-4.8L2.5 38.4c2.3 3.6 6 6.9 10.8 9.8C5 53 0 59 0 65.5c0 6.4 4.8 12.3 12.9 17.1C4.8 87.3 0 93.2 0 99.6 0 115.3 28.6 128 64 128c35.3 0 64-12.7 64-28.4 0-6.4-4.8-12.3-12.9-17 8.1-4.8 12.9-10.7 12.9-17.1 0-6.5-5-12.6-13.4-17.4 8.3-5.1 13.3-11.4 13.3-18.2 0-16.5-28.7-29.9-64-29.9zm22.8 14.2c-5.2.1-10.2 1.2-13.4 3.3-5.5 3.6-3.8 8.5 3.8 11.1 7.6 2.6 18.1 1.8 23.6-1.8s3.8-8.5-3.8-11c-3.1-1-6.7-1.5-10.2-1.5zm.3 1.7c7.4 0 13.3 2.8 13.3 6.2 0 3.4-5.9 6.2-13.3 6.2s-13.3-2.8-13.3-6.2c0-3.4 5.9-6.2 13.3-6.2zM45.3 34.4c-1.6.1-3.1.2-4.6.4l9.1 1.7a10.8 5 0 1 1-8.1 9.3l-8.9-1.7c1 .9 2.4 1.7 4.3 2.4 6.4 2.2 15.4 1.5 20-1.5s3.2-7.2-3.2-9.3c-2.6-.9-5.7-1.3-8.6-1.3zM109 51v9.3c0 11-20.2 19.9-45 19.9-24.9 0-45-8.9-45-19.9v-9.2c11.5 5.3 27.4 8.6 44.9 8.6 17.6 0 33.6-3.3 45.2-8.7zm0 34.6v8.8c0 11-20.2 19.9-45 19.9-24.9 0-45-8.9-45-19.9v-8.8c11.6 5.1 27.4 8.2 45 8.2s33.5-3.1 45-8.2z" /></svg> <span>SteamDB</span></a>
<form class="header-search" id="js-header-form" method="get" action="/search/" itemprop="potentialAction" itemscope itemtype="http://schema.org/SearchAction" role="search">
<input type="hidden" name="a" value="app">
<meta itemprop="target" content="https://steamdb.info/search/?a=app&amp;q={q}">
<input type="text" accesskey="/" class="field" autocomplete="off" name="q" placeholder="Search…" itemprop="query-input" aria-label="Search">
<button type="submit" class="submit" aria-label="Perform search" tabindex="-1"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-search" aria-hidden="true"><path fill-rule="evenodd" d="M11.5 7a4.499 4.499 0 11-8.998 0A4.499 4.499 0 0111.5 7zm-.82 4.74a6 6 0 111.06-1.06l3.04 3.04a.75.75 0 11-1.06 1.06l-3.04-3.04z"></path></svg></button>
</form>
<a href="/sales/">Sales</a>
<a href="/graph/">Charts</a>
<a href="/calculator/">Calculator</a>
<a href="/patchnotes/">Patch notes</a>
<a href="/upcoming/">Upcoming</a>
<button type="button" class="btn btn-outline header-search-close">Close</button>
</div>
<button type="button" class="header-search-mobile" aria-label="Open search"><svg version="1.1" width="24" height="24" viewBox="0 0 16 16" class="octicon octicon-search" aria-hidden="true"><path fill-rule="evenodd" d="M11.5 7a4.499 4.499 0 11-8.998 0A4.499 4.499 0 0111.5 7zm-.82 4.74a6 6 0 111.06-1.06l3.04 3.04a.75.75 0 11-1.06 1.06l-3.04-3.04z"></path></svg></button>
<div class="header-user hide-small">
<a class="header-login" href="/login/?page=patchnotes%2F9775839" rel="nofollow">
<svg version="1.1" width="20" height="20" viewBox="0 0 16 16" class="octicon octicon-steam" aria-hidden="true"><path d="M8 0a8 8 0 00-8 7.47c.07.1.13.21.18.32l4.15 1.67a2.2 2.2 0 011.31-.36l1.97-2.8v-.04c0-1.65 1.37-3 3.05-3a3.03 3.03 0 013.05 3 3.03 3.03 0 01-3.12 3l-2.81 1.97c0 .3-.05.6-.17.9a2.25 2.25 0 01-4.23-.37L.4 10.56A8.01 8.01 0 108 0zm2.66 4.27c-1.12 0-2.03.9-2.03 2s.91 1.99 2.03 1.99c1.12 0 2.03-.9 2.03-2s-.9-2-2.03-2zm0 .5c.85 0 1.53.66 1.53 1.49s-.68 1.5-1.53 1.5c-.84 0-1.52-.67-1.52-1.5s.68-1.5 1.52-1.5zM5.57 9.6c-.22 0-.43.04-.62.11l1.02.42c.65.26.95.99.68 1.62-.27.63-1 .93-1.65.67l-1-.4a1.73 1.73 0 003.13-.08c.18-.42.18-.88.01-1.3A1.69 1.69 0 005.57 9.6z" /></svg> <span>Sign in</span>
</a>
</div>
</div>
<div class="header-search-suggestions">
<div class="container" id="js-search-tips">
<p>Start typing to see game suggestions. This only suggests apps that have a store page.</p>
<ul>
<li class="hide-small">Use slash key (<kbd>/</kbd>) to focus search from anywhere.</li>
<li class="hide-small">Use arrow keys (<kbd>↑</kbd> and <kbd>↓</kbd>) to navigate suggestions.</li>
<li class="hide-small">Use escape (<kbd>Esc</kbd>) to close search.</li>
<li>Enter an appid to be redirected to the app page.</li>
<li>Enter a steamid (765...) to be redirected to calculator.</li>
<li>Paste a profile link (/id/ or /profiles/) to be redirected to calculator.</li>
<li>Paste any url that contains app/, sub/, bundle/, or depot/ to be redirected to the relevant page.</li>
</ul>
</div>
<div class="container" id="js-search-suggestions"></div>
<div class="container header-search-enter">
Only apps with a store page are suggested.
<span class="hide-small">
<kbd>Enter</kbd> Submit to view all results.
<kbd>Ctrl+Enter</kbd> View and filter in instant search.
</span>
</div>
<div class="header-search-side-close">
<div class="header-search-side-close-inner">Close &times;</div>
</div>
</div>
<div class="header-menu-container" hidden>
<div class="header-menu" tabindex="0">
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-info" aria-hidden="true"><path fill-rule="evenodd" d="M8 1.5a6.5 6.5 0 100 13 6.5 6.5 0 000-13zM0 8a8 8 0 1116 0A8 8 0 010 8zm6.5-.25A.75.75 0 017.25 7h1a.75.75 0 01.75.75v2.75h.25a.75.75 0 010 1.5h-2a.75.75 0 010-1.5h.25v-2h-.25a.75.75 0 01-.75-.75zM8 6a1 1 0 100-2 1 1 0 000 2z"></path></svg> About</li>
<li><a href="/blog/">Blog</a></li>
<li><a href="/discord/">Discord</a></li>
<li><a href="/faq/">FAQ &amp; help</a></li>
<li><a href="/donate/">Donate &amp; contribute</a></li>
<li><a href="/extension/">Browser extension</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-search" aria-hidden="true"><path fill-rule="evenodd" d="M11.5 7a4.499 4.499 0 11-8.998 0A4.499 4.499 0 0111.5 7zm-.82 4.74a6 6 0 111.06-1.06l3.04 3.04a.75.75 0 11-1.06 1.06l-3.04-3.04z"></path></svg> Tools</li>
<li><a href="/sales/">Sales</a></li>
<li><a href="/graph/">Charts</a></li>
<li><a href="/calculator/">Calculator</a></li>
<li><a href="/patchnotes/">Patch notes</a></li>
<li><a href="/search/">Search</a></li>
<li><a href="/instantsearch/">Instant search</a></li>
<li><a href="/sales/history/">When is next sale?</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-sync" aria-hidden="true"><path fill-rule="evenodd" d="M8 2.5a5.487 5.487 0 00-4.131 1.869l1.204 1.204A.25.25 0 014.896 6H1.25A.25.25 0 011 5.75V2.104a.25.25 0 01.427-.177l1.38 1.38A7.001 7.001 0 0114.95 7.16a.75.75 0 11-1.49.178A5.501 5.501 0 008 2.5zM1.705 8.005a.75.75 0 01.834.656 5.501 5.501 0 009.592 2.97l-1.204-1.204a.25.25 0 01.177-.427h3.646a.25.25 0 01.25.25v3.646a.25.25 0 01-.427.177l-1.38-1.38A7.001 7.001 0 011.05 8.84a.75.75 0 01.656-.834z"></path></svg> Tracking</li>
<li><a href="/apps/">Apps</a></li>
<li><a href="/subs/">Packages</a></li>
<li><a href="/bundles/">Bundles</a></li>
<li><a href="/history/">History</a></li>
<li><a href="/pricechanges/">Price changes</a></li>
<li><a href="/upcoming/free/">Free promotions</a></li>
<li><a href="/tech/">Technologies &amp; built with</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-database" aria-hidden="true"><path fill-rule="evenodd" d="M2.5 3.5c0-.133.058-.318.282-.55.227-.237.592-.484 1.1-.708C4.899 1.795 6.354 1.5 8 1.5c1.647 0 3.102.295 4.117.742.51.224.874.47 1.101.707.224.233.282.418.282.551 0 .133-.058.318-.282.55-.227.237-.592.484-1.1.708C11.101 5.205 9.646 5.5 8 5.5c-1.647 0-3.102-.295-4.117-.742-.51-.224-.874-.47-1.101-.707-.224-.233-.282-.418-.282-.551zM1 3.5c0-.626.292-1.165.7-1.59.406-.422.956-.767 1.579-1.041C4.525.32 6.195 0 8 0c1.805 0 3.475.32 4.722.869.622.274 1.172.62 1.578 1.04.408.426.7.965.7 1.591v9c0 .626-.292 1.165-.7 1.59-.406.422-.956.767-1.579 1.041C11.476 15.68 9.806 16 8 16c-1.805 0-3.475-.32-4.721-.869-.623-.274-1.173-.62-1.579-1.04-.408-.426-.7-.965-.7-1.591v-9zM2.5 8V5.724c.241.15.503.286.779.407C4.525 6.68 6.195 7 8 7c1.805 0 3.475-.32 4.722-.869.275-.121.537-.257.778-.407V8c0 .133-.058.318-.282.55-.227.237-.592.484-1.1.708C11.101 9.705 9.646 10 8 10c-1.647 0-3.102-.295-4.117-.742-.51-.224-.874-.47-1.101-.707C2.558 8.318 2.5 8.133 2.5 8zm0 2.225V12.5c0 .133.058.318.282.55.227.237.592.484 1.1.708 1.016.447 2.471.742 4.118.742 1.647 0 3.102-.295 4.117-.742.51-.224.874-.47 1.101-.707.224-.233.282-.418.282-.551v-2.275c-.241.15-.503.285-.778.406-1.247.549-2.917.869-4.722.869-1.805 0-3.475-.32-4.721-.869a6.236 6.236 0 01-.779-.406z"></path></svg> Database</li>
<li><a href="/tags/">User tags</a></li>
<li><a href="/upcoming/">Upcoming releases</a></li>
<li><a href="/upcoming/mostfollowed/">Most followed upcoming</a></li>
<li><a href="/calendar/">Release calendar</a></li>
<li><a href="/stats/releases/">Game releases by year</a></li>
<li><a href="/badges/">Profile badges</a></li>
<li><a href="/developers/">Developers</a></li>
<li><a href="/publishers/">Publishers</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-number" aria-hidden="true"><path fill-rule="evenodd" d="M5.604.089A.75.75 0 016 .75v4.77h.711a.75.75 0 110 1.5H3.759a.75.75 0 110-1.5H4.5V2.15l-.334.223a.75.75 0 01-.832-1.248l1.5-1a.75.75 0 01.77-.037zM9 4.75A.75.75 0 019.75 4h4a.75.75 0 01.53 1.28l-1.89 1.892c.312.076.604.18.867.319.742.391 1.244 1.063 1.244 2.005 0 .653-.231 1.208-.629 1.627-.386.408-.894.653-1.408.777-1.01.243-2.225.063-3.124-.527a.75.75 0 01.822-1.254c.534.35 1.32.474 1.951.322.306-.073.53-.201.67-.349.129-.136.218-.32.218-.596 0-.308-.123-.509-.444-.678-.373-.197-.98-.318-1.806-.318a.75.75 0 01-.53-1.28l1.72-1.72H9.75A.75.75 0 019 4.75zm-3.587 5.763c-.35-.05-.77.113-.983.572a.75.75 0 11-1.36-.632c.508-1.094 1.589-1.565 2.558-1.425 1 .145 1.872.945 1.872 2.222 0 1.433-1.088 2.192-1.79 2.681-.308.216-.571.397-.772.573H7a.75.75 0 010 1.5H3.75a.75.75 0 01-.75-.75c0-.69.3-1.211.67-1.61.348-.372.8-.676 1.15-.92.8-.56 1.18-.904 1.18-1.474 0-.473-.267-.69-.587-.737z"></path></svg> Rankings</li>
<li><a href="/stats/gameratings/">Top rated games</a></li>
<li><a href="/badge/13/">Top game owners</a></li>
<li><a href="/stats/toplevels/">Top profile levels</a></li>
<li><a href="/stats/globaltopsellers/">Top selling games</a></li>
<li><a href="/topsellers/">Top selling games last week</a></li>
<li><a href="/stats/mostfollowed/">Most followed games</a></li>
<li><a href="/stats/mostwished/">Most wishlisted games</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-person" aria-hidden="true"><path fill-rule="evenodd" d="M10.5 5a2.5 2.5 0 11-5 0 2.5 2.5 0 015 0zm.061 3.073a4 4 0 10-5.123 0 6.004 6.004 0 00-3.431 5.142.75.75 0 001.498.07 4.5 4.5 0 018.99 0 .75.75 0 101.498-.07 6.005 6.005 0 00-3.432-5.142z"></path></svg> Account</li>
<li><a href="/login/?page=patchnotes%2F9775839" rel="nofollow">Sign in via Steam</a></li>
<li><a href="/freepackages/">Free packages</a></li>
<li>&nbsp;</li>
<li><a href="https://steamstat.us/">Steam Status</a></li>
<li><a href="https://steamapi.xpaw.me/">Steam Web API</a></li>
</ul>
<div class="header-disclaimer">SteamDB is a hobby project and is not affiliated with Valve or Steam.<br>All times on the site are UTC.</div>
<div class="header-kbd hide-small"><kbd>M</kbd> toggle this menu <kbd>/</kbd> focus search</div>
</div>
</div>
<script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=" integrity="sha512-wtG9C3m3eSznE1WGU+3yesEal8fZvdYoqttyeGF5WmdHVOwXsA4OyBkKJarOFc0nAo+A+J+BNBn+XF/aoR+3rg==" src="/static/js/global.js?v=c2d1bd0b79b7792c"></script>
<div class="body-wrap">
<div class="body-content" id="main">
<div class="patchnotes" itemscope itemtype="http://schema.org/Article">
<meta itemprop="mainEntityOfPage" content="https://steamdb.info/patchnotes/9775839/">
<meta itemprop="image" content="https://steamdb.info/patchnotes/9775839.png?_=1666413966">
<meta itemprop="datePublished" content="2022-10-22T04:42:08+00:00">
<meta itemprop="author" content="SteamDB">
<span itemscope itemtype="http://schema.org/Organization" itemprop="publisher">
<meta itemprop="name" content="SteamDB">
<meta itemprop="url" content="https://steamdb.info/">
<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://steamdb.info/static/logos/512px.png">
<meta itemprop="width" content="512">
<meta itemprop="height" content="512">
</span>
</span>
<div class="header-wrapper" style="background:#1b2838;background-position:center top;background-image:url('https://cdn.cloudflare.steamstatic.com/steam/apps/1957860/page_bg_generated_v6b.jpg?t=1666413728')">
<div class="container">
<h1 class="header-title" itemprop="headline">
<a href="/app/1957860/" class="app" data-appid="1957860">Anna VS the A.I.maze</a> update for 22 October 2022
</h1>
<h2 class="header-subtitle" itemprop="alternativeHeadline">Another small fix for memory cleanup</h2>
<p class="patchnotes-editor d-flex">
<span class="flex-grow">
<share-action role="button" tabindex="0"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-share-android" aria-hidden="true"><path fill-rule="evenodd" d="M13.5 3a1.5 1.5 0 11-3 0 1.5 1.5 0 013 0zM15 3a3 3 0 01-5.175 2.066l-3.92 2.179a3.005 3.005 0 010 1.51l3.92 2.179a3 3 0 11-.73 1.31l-3.92-2.178a3 3 0 110-4.133l3.92-2.178A3 3 0 1115 3zm-1.5 10a1.5 1.5 0 11-3 0 1.5 1.5 0 013 0zm-9-5a1.5 1.5 0 11-3 0 1.5 1.5 0 013 0z"></path></svg> Share</share-action> ·
<a href="/app/1957860/patchnotes/">View all patches</a> · <a href="/app/1957860/history/?changeid=16451349" rel="nofollow">Build 9775839</a> · Last edited <time class="timeago" datetime="2022-10-22T04:46:06+00:00" itemprop="dateModified" content="2022-10-22T04:46:06+00:00">22 October 2022 – 04:46:06 UTC</time>
by <img class="avatar" src="https://avatars.cloudflare.steamstatic.com/ce048935d2d12dc1746f563d661a9e6ae6631c09_full.jpg" width="16" height="16" alt=""> <a rel="nofollow" href="/calculator/76561198074261126/">Wendy</a>
</span>
</p>
</div>
</div>
<div class="container">
<div class="patchnotes-official-url patchnotes-check">
<svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-check-circle-fill" aria-hidden="true"><path fill-rule="evenodd" d="M8 16A8 8 0 108 0a8 8 0 000 16zm3.78-9.72a.75.75 0 00-1.06-1.06L6.75 9.19 5.28 7.72a.75.75 0 00-1.06 1.06l2 2a.75.75 0 001.06 0l4.5-4.5z"></path></svg> Patchnotes via <a class="b" href="https://steamcommunity.com/games/1957860/announcements/detail/3401932464043788440">Steam Community</a>
</div>
</div>
<div class="container markdown-body patchnotes-official" itemprop="articleBody"><p>Just bug fix of memory cleanup</p></div>
</div>
<div class="container">
<div class="depot-history" id="changed-files">
<div class="comments-header">
<h2><a href="#changed-files" style="color:inherit">Changed files in this update</a></h2>
</div>
<div class="panel" id="js-depot-not-owned" hidden>
<p>Some depots below may not display changed files because our bot does not own the specific depot or game.</p>
<p><a href="/donate/">Game can be donated with a key, by sending a gift, or using curator system.</a></p>
</div>
<div class="panel panel-history">
<div class="panel-heading d-flex">
<span class="flex-grow"></span>
<a href="/depot/1957861/history/?changeid=M:3690743039997616634" class="muted">Depot 1957861</a>
</div>
<ul class="app-history" id="js-depot-1957861"><li>Loading history…</li></ul>
</div>
</div>
</div>
<script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=" integrity="sha512-eJ81wii68Lg64cprrE8gYqo/JrLKqtYIbSYOE5uO3jYmb+Z2vIwLLsM54gIU2q1wOzk8uJiNxXaBZgn2njj4BA==" src="/static/js/share.js?v=789f35c228baf0b8" defer></script><script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=" integrity="sha512-hq5SKgGD08UdZrD5s36/UVkEwkjYQyA+xU5K9Oaw785YFiREOIK3JQrlg2u966Dqm950X+L4v2IKYupr2bQpaQ==" src="/static/js/lite-youtube.js?v=86ae522a0183d3c5" defer></script><script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=" integrity="sha512-5RT/a1kRlzVqwHFS6hm+81Mb59VzyMjE5mINA2EAVCXiYPULvEvKVPSsjMMKFaZsuRNP2Tvg00l0sSUko2nPdw==" src="/static/js/timeago.js?v=e514ff6b59119735"></script>
<script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=">TimeAgo.initAll( '.timeago' );</script>
<script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=" integrity="sha512-NO/kzezYPc6pX1+rDDDJgiCLhhmbRbQLssWh5jKQtPZM8KPQYaYferewqcWPr89dA9ucrJKBwl0KudwyempSnQ==" src="/static/js/vendor/diff_match_patch.js?v=34efe4cdecd83dce" defer></script><script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=" integrity="sha512-vkRNeEElPi/Sp/9ZCVheMpiDXNtJQeZfNdVwOfH3zIqhG9LmJ0EVuTHgJeGhD6d1uXspQJ8dt5zkbmxwz7lewA==" src="/static/js/history.js?v=be444d7841253e2f" defer></script>
<script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=">
(function()
{
const depots = [{"DepotID":1957861,"ManifestID":"3690743039997616634"}];
ObserveNextDepot( depots.shift() );
function ObserveNextDepot( depot )
{
window.SteamDB.LazyLoad(
document.getElementById( `js-depot-${depot.DepotID}` ),
() => GetDepotHistory( depot )
);
}
function GetDepotHistory( depot )
{
const params = new URLSearchParams();
params.append( 'lastentry', 0 );
params.append( 'depotid', depot.DepotID );
params.append( 'changeid', depot.ManifestID > 0 ? 'M:' + depot.ManifestID : 16451349 );
fetch( `/api/GetDepotHistory/?${params.toString()}`, {
headers: {
Accept: 'text/html',
'X-Requested-With': 'XMLHttpRequest'
}
} )
.then( response =>
{
const nextDepot = depots.shift();
const element = document.getElementById( `js-depot-${depot.DepotID}` );
const lastChangeID = response.headers.get( 'X-SteamDB-History-LastChangeID' );
if( lastChangeID === null )
{
element.closest( '.panel' ).remove();
if( nextDepot )
{
setTimeout( () => ObserveNextDepot( nextDepot ), 100 );
}
return;
}
response.text().then( rawHtml =>
{
const html = document.createElement( 'div' );
html.innerHTML = rawHtml;
const innerHistory = html.querySelector( '.app-history' );
if( innerHistory.childElementCount <= 1 )
{
document.getElementById( 'js-depot-not-owned' ).hidden = false;
}
element.parentNode.replaceChild( innerHistory, element );
if( nextDepot )
{
setTimeout( () => ObserveNextDepot( nextDepot ), 100 );
}
} );
} )
.catch( ( e ) =>
{
window.SteamDB.Alert( 'Failed to load history: ' + e );
throw e;
} );
}
}());
</script>
</div>
<a href="/donate/" class="welding-torch hide-small">
<span>SteamDB has been running ad-free since 2012.<br><b>Find out how you can contribute.</b></span>
<svg version="1.1" width="32" height="32" viewBox="0 0 16 16" class="octicon octicon-chevron-right" aria-hidden="true"><path fill-rule="evenodd" d="M6.22 3.22a.75.75 0 011.06 0l4.25 4.25a.75.75 0 010 1.06l-4.25 4.25a.75.75 0 01-1.06-1.06L9.94 8 6.22 4.28a.75.75 0 010-1.06z"></path></svg>
</a>
<div class="footer" role="contentinfo" id="steamdb-org" itemscope itemtype="http://schema.org/Organization" itemprop="publisher">
<meta itemprop="name" content="SteamDB">
<meta itemprop="url" content="https://steamdb.info/">
<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://steamdb.info/static/logos/512px.png">
<meta itemprop="width" content="512">
<meta itemprop="height" content="512">
</span>
<div class="footer-container">
<div class="footer-menu hide-small">
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-info" aria-hidden="true"><path fill-rule="evenodd" d="M8 1.5a6.5 6.5 0 100 13 6.5 6.5 0 000-13zM0 8a8 8 0 1116 0A8 8 0 010 8zm6.5-.25A.75.75 0 017.25 7h1a.75.75 0 01.75.75v2.75h.25a.75.75 0 010 1.5h-2a.75.75 0 010-1.5h.25v-2h-.25a.75.75 0 01-.75-.75zM8 6a1 1 0 100-2 1 1 0 000 2z"></path></svg> About</li>
<li><a href="/blog/">Blog</a></li>
<li><a href="/discord/">Discord</a></li>
<li><a href="/faq/">FAQ &amp; help</a></li>
<li><a href="/donate/">Donate &amp; contribute</a></li>
<li><a href="/extension/">Browser extension</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-search" aria-hidden="true"><path fill-rule="evenodd" d="M11.5 7a4.499 4.499 0 11-8.998 0A4.499 4.499 0 0111.5 7zm-.82 4.74a6 6 0 111.06-1.06l3.04 3.04a.75.75 0 11-1.06 1.06l-3.04-3.04z"></path></svg> Tools</li>
<li><a href="/sales/">Sales</a></li>
<li><a href="/graph/">Charts</a></li>
<li><a href="/calculator/">Calculator</a></li>
<li><a href="/patchnotes/">Patch notes</a></li>
<li><a href="/search/">Search</a></li>
<li><a href="/instantsearch/">Instant search</a></li>
<li><a href="/sales/history/">When is next sale?</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-sync" aria-hidden="true"><path fill-rule="evenodd" d="M8 2.5a5.487 5.487 0 00-4.131 1.869l1.204 1.204A.25.25 0 014.896 6H1.25A.25.25 0 011 5.75V2.104a.25.25 0 01.427-.177l1.38 1.38A7.001 7.001 0 0114.95 7.16a.75.75 0 11-1.49.178A5.501 5.501 0 008 2.5zM1.705 8.005a.75.75 0 01.834.656 5.501 5.501 0 009.592 2.97l-1.204-1.204a.25.25 0 01.177-.427h3.646a.25.25 0 01.25.25v3.646a.25.25 0 01-.427.177l-1.38-1.38A7.001 7.001 0 011.05 8.84a.75.75 0 01.656-.834z"></path></svg> Tracking</li>
<li><a href="/apps/">Apps</a></li>
<li><a href="/subs/">Packages</a></li>
<li><a href="/bundles/">Bundles</a></li>
<li><a href="/history/">History</a></li>
<li><a href="/pricechanges/">Price changes</a></li>
<li><a href="/upcoming/free/">Free promotions</a></li>
<li><a href="/tech/">Technologies &amp; built with</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-database" aria-hidden="true"><path fill-rule="evenodd" d="M2.5 3.5c0-.133.058-.318.282-.55.227-.237.592-.484 1.1-.708C4.899 1.795 6.354 1.5 8 1.5c1.647 0 3.102.295 4.117.742.51.224.874.47 1.101.707.224.233.282.418.282.551 0 .133-.058.318-.282.55-.227.237-.592.484-1.1.708C11.101 5.205 9.646 5.5 8 5.5c-1.647 0-3.102-.295-4.117-.742-.51-.224-.874-.47-1.101-.707-.224-.233-.282-.418-.282-.551zM1 3.5c0-.626.292-1.165.7-1.59.406-.422.956-.767 1.579-1.041C4.525.32 6.195 0 8 0c1.805 0 3.475.32 4.722.869.622.274 1.172.62 1.578 1.04.408.426.7.965.7 1.591v9c0 .626-.292 1.165-.7 1.59-.406.422-.956.767-1.579 1.041C11.476 15.68 9.806 16 8 16c-1.805 0-3.475-.32-4.721-.869-.623-.274-1.173-.62-1.579-1.04-.408-.426-.7-.965-.7-1.591v-9zM2.5 8V5.724c.241.15.503.286.779.407C4.525 6.68 6.195 7 8 7c1.805 0 3.475-.32 4.722-.869.275-.121.537-.257.778-.407V8c0 .133-.058.318-.282.55-.227.237-.592.484-1.1.708C11.101 9.705 9.646 10 8 10c-1.647 0-3.102-.295-4.117-.742-.51-.224-.874-.47-1.101-.707C2.558 8.318 2.5 8.133 2.5 8zm0 2.225V12.5c0 .133.058.318.282.55.227.237.592.484 1.1.708 1.016.447 2.471.742 4.118.742 1.647 0 3.102-.295 4.117-.742.51-.224.874-.47 1.101-.707.224-.233.282-.418.282-.551v-2.275c-.241.15-.503.285-.778.406-1.247.549-2.917.869-4.722.869-1.805 0-3.475-.32-4.721-.869a6.236 6.236 0 01-.779-.406z"></path></svg> Database</li>
<li><a href="/tags/">User tags</a></li>
<li><a href="/upcoming/">Upcoming releases</a></li>
<li><a href="/upcoming/mostfollowed/">Most followed upcoming</a></li>
<li><a href="/calendar/">Release calendar</a></li>
<li><a href="/stats/releases/">Game releases by year</a></li>
<li><a href="/badges/">Profile badges</a></li>
<li><a href="/developers/">Developers</a></li>
<li><a href="/publishers/">Publishers</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-number" aria-hidden="true"><path fill-rule="evenodd" d="M5.604.089A.75.75 0 016 .75v4.77h.711a.75.75 0 110 1.5H3.759a.75.75 0 110-1.5H4.5V2.15l-.334.223a.75.75 0 01-.832-1.248l1.5-1a.75.75 0 01.77-.037zM9 4.75A.75.75 0 019.75 4h4a.75.75 0 01.53 1.28l-1.89 1.892c.312.076.604.18.867.319.742.391 1.244 1.063 1.244 2.005 0 .653-.231 1.208-.629 1.627-.386.408-.894.653-1.408.777-1.01.243-2.225.063-3.124-.527a.75.75 0 01.822-1.254c.534.35 1.32.474 1.951.322.306-.073.53-.201.67-.349.129-.136.218-.32.218-.596 0-.308-.123-.509-.444-.678-.373-.197-.98-.318-1.806-.318a.75.75 0 01-.53-1.28l1.72-1.72H9.75A.75.75 0 019 4.75zm-3.587 5.763c-.35-.05-.77.113-.983.572a.75.75 0 11-1.36-.632c.508-1.094 1.589-1.565 2.558-1.425 1 .145 1.872.945 1.872 2.222 0 1.433-1.088 2.192-1.79 2.681-.308.216-.571.397-.772.573H7a.75.75 0 010 1.5H3.75a.75.75 0 01-.75-.75c0-.69.3-1.211.67-1.61.348-.372.8-.676 1.15-.92.8-.56 1.18-.904 1.18-1.474 0-.473-.267-.69-.587-.737z"></path></svg> Rankings</li>
<li><a href="/stats/gameratings/">Top rated games</a></li>
<li><a href="/badge/13/">Top game owners</a></li>
<li><a href="/stats/toplevels/">Top profile levels</a></li>
<li><a href="/stats/globaltopsellers/">Top selling games</a></li>
<li><a href="/topsellers/">Top selling games last week</a></li>
<li><a href="/stats/mostfollowed/">Most followed games</a></li>
<li><a href="/stats/mostwished/">Most wishlisted games</a></li>
</ul>
<ul>
<li class="navigation-heading"><svg version="1.1" width="16" height="16" viewBox="0 0 16 16" class="octicon octicon-person" aria-hidden="true"><path fill-rule="evenodd" d="M10.5 5a2.5 2.5 0 11-5 0 2.5 2.5 0 015 0zm.061 3.073a4 4 0 10-5.123 0 6.004 6.004 0 00-3.431 5.142.75.75 0 001.498.07 4.5 4.5 0 018.99 0 .75.75 0 101.498-.07 6.005 6.005 0 00-3.432-5.142z"></path></svg> Account</li>
<li><a href="/login/?page=patchnotes%2F9775839" rel="nofollow">Sign in via Steam</a></li>
<li><a href="/freepackages/">Free packages</a></li>
<li>&nbsp;</li>
<li><a href="https://steamstat.us/">Steam Status</a></li>
<li><a href="https://steamapi.xpaw.me/">Steam Web API</a></li>
</ul>
</div>
<div class="footer-copyright">
<div>
<p>
SteamDB is a hobby project and is not affiliated with Valve or Steam. All times on the site are UTC.
<a href="/faq/#what-steamdb-is-not">Fair use disclaimer</a> &middot;
<a href="/faq/#privacy">Privacy</a>
</p>
<p>Steam and the Steam logo are trademarks of Valve Corporation. All other trademarks are property of their respective owners.</p>
</div>
<div class="footer-buttons">
<a class="btn-social tooltipped tooltipped-n" aria-label="Discord" href="/discord/" rel="nofollow">
<svg viewBox="0 0 16 16" width="24" height="24" class="btn-social-icon" aria-hidden="true">
<path d="M13.54 2.9a13.2 13.2 0 00-3.25-1c-.02 0-.04 0-.05.02-.15.25-.3.58-.41.83a12.18 12.18 0 00-3.66 0 8.4 8.4 0 00-.41-.83.05.05 0 00-.05-.02 13.16 13.16 0 00-3.28 1.03 13.5 13.5 0 00-2.34 9.14c1.37 1 2.7 1.61 4 2.02.01 0 .04 0 .05-.02.3-.42.58-.86.82-1.33a.05.05 0 00-.03-.07 8.76 8.76 0 01-1.25-.6.05.05 0 010-.08l.24-.2a.05.05 0 01.05 0 9.46 9.46 0 008.05 0h.05l.25.2c.03.02.02.07 0 .09-.4.23-.82.43-1.26.59a.05.05 0 00-.02.07c.24.47.51.91.81 1.33.02.02.04.03.06.02a13.23 13.23 0 004.02-2.06 13.41 13.41 0 00-2.39-9.12zm-8.2 7.31c-.78 0-1.43-.72-1.43-1.6 0-.9.64-1.62 1.44-1.62.8 0 1.45.73 1.43 1.61 0 .89-.63 1.61-1.43 1.61zm5.32 0c-.79 0-1.43-.72-1.43-1.6 0-.9.63-1.62 1.43-1.62.81 0 1.45.73 1.44 1.61 0 .89-.63 1.61-1.44 1.61z" />
</svg>
</a>
<a class="btn-social tooltipped tooltipped-n" aria-label="Twitter" href="https://twitter.com/intent/follow?screen_name=SteamDB" itemprop="sameAs">
<svg viewBox="0 0 32 32" width="24" height="24" class="btn-social-icon" aria-hidden="true">
<path d="M31.993 6.077c-1.177.523-2.44.876-3.77 1.033 1.355-.812 2.396-2.098 2.887-3.63-1.27.75-2.673 1.3-4.168 1.592C25.744 3.797 24.038 3 22.15 3c-3.626 0-6.563 2.938-6.563 6.563 0 .514.057 1.016.17 1.496C10.3 10.784 5.464 8.17 2.226 4.2c-.564.97-.888 2.098-.888 3.3 0 2.28 1.158 4.287 2.918 5.465-1.075-.035-2.087-.33-2.972-.82v.08c0 3.182 2.26 5.835 5.264 6.438-.55.15-1.13.23-1.73.23-.423 0-.833-.04-1.233-.117.834 2.606 3.26 4.504 6.13 4.558-2.245 1.76-5.075 2.81-8.15 2.81-.53 0-1.053-.03-1.566-.09C2.906 27.913 6.356 29 10.063 29c12.072 0 18.675-10 18.675-18.675 0-.284-.008-.568-.02-.85 1.283-.925 2.395-2.08 3.276-3.398z" />
</svg>
</a>
<a class="btn-social tooltipped tooltipped-n" aria-label="GitHub" href="https://github.com/SteamDatabase" itemprop="sameAs">
<svg viewBox="0 0 16 16" width="24" height="24" class="btn-social-icon" aria-hidden="true">
<path fill-rule="evenodd" d="M8 0C3.58 0 0 3.58 0 8c0 3.54 2.29 6.53 5.47 7.59.4.07.55-.17.55-.38 0-.19-.01-.82-.01-1.49-2.01.37-2.53-.49-2.69-.94-.09-.23-.48-.94-.82-1.13-.28-.15-.68-.52-.01-.53.63-.01 1.08.58 1.23.82.72 1.21 1.87.87 2.33.66.07-.52.28-.87.51-1.07-1.78-.2-3.64-.89-3.64-3.95 0-.87.31-1.59.82-2.15-.08-.2-.36-1.02.08-2.12 0 0 .67-.21 2.2.82.64-.18 1.32-.27 2-.27.68 0 1.36.09 2 .27 1.53-1.04 2.2-.82 2.2-.82.44 1.1.16 1.92.08 2.12.51.56.82 1.27.82 2.15 0 3.07-1.87 3.75-3.65 3.95.29.25.54.73.54 1.48 0 1.07-.01 1.93-.01 2.2 0 .21.15.46.55.38A8.013 8.013 0 0 0 16 8c0-4.42-3.58-8-8-8z"></path>
</svg>
</a>
<a class="btn-social tooltipped tooltipped-n" aria-label="Steam Group" href="https://steamcommunity.com/groups/steamdb" itemprop="sameAs">
<svg viewBox="0 0 16 16" width="24" height="24" class="btn-social-icon" aria-hidden="true">
<path d="M8 0a8 8 0 00-8 7.47c.07.1.13.21.18.32l4.15 1.67a2.2 2.2 0 011.31-.36l1.97-2.8v-.04c0-1.65 1.37-3 3.05-3a3.03 3.03 0 013.05 3 3.03 3.03 0 01-3.12 3l-2.81 1.97c0 .3-.05.6-.17.9a2.25 2.25 0 01-4.23-.37L.4 10.56A8.01 8.01 0 108 0zm2.66 4.27c-1.12 0-2.03.9-2.03 2s.91 1.99 2.03 1.99c1.12 0 2.03-.9 2.03-2s-.9-2-2.03-2zm0 .5c.85 0 1.53.66 1.53 1.49s-.68 1.5-1.53 1.5c-.84 0-1.52-.67-1.52-1.5s.68-1.5 1.52-1.5zM5.57 9.6c-.22 0-.43.04-.62.11l1.02.42c.65.26.95.99.68 1.62-.27.63-1 .93-1.65.67l-1-.4a1.73 1.73 0 003.13-.08c.18-.42.18-.88.01-1.3A1.69 1.69 0 005.57 9.6z"></path>
</svg>
</a>
</div>
</div>
</div>
</div>
</div>
<div id="js-notifications">
<noscript>
<div class="toast-header"><b>Enable JavaScript</b></div>
<div class="toast-body">For SteamDB to function correctly, JavaScript should be enabled.</div>
</noscript>
</div>
<div id="js-hover" hidden></div>
<div id="js-screenshots">
<div class="screenshot-header">
<span>
<a href="#" class="screenshot-name"></a>
</span>
<span>
<button type="button" class="btn btn-sm btn-primary screenshot-prev">← Prev</button>
<span class="screenshot-index"></span>
<button type="button" class="btn btn-sm btn-primary screenshot-next">Next →</button>
</span>
<span>
<a href="#" target="_blank" rel="noopener" class="btn btn-sm screenshot-open">Open link</a>
<button type="button" class="btn btn-sm btn-danger screenshot-close">Close<span class="hide-small"> (Esc)</span></button>
</span>
</div>
<div class="screenshot-contain"></div>
</div>
<script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=" integrity="sha512-cZ7XmQ71sKRsQTDAwGqz2pbhGPDxD9j2fSMNyX/JP9i/2b7oKxeWQF2kjGwNeeokNsd1uz10cadNGsg+YEM4QA==" src="/static/js/footer.js?v=719ed7990ef5b0a4" defer></script><script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=" integrity="sha512-szodDipYlK3BuXrEtu+R5I83ffTZBPmrcAeLCLp8fYlAutGX6BM3HrCHUBKDNjdazhpJLe9G/gKDXhPwNZXBrQ==" src="/static/js/hover.js?v=b33a1d0e2a5894ad" defer></script><script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=" integrity="sha512-1ybGGSXu45WDVLpQVF82WqtnS2bxLx/FPHJTns9Vs3s6fB+Z9IRphuQHYGo6iv2bFbVXVRuQ2xNJLdKPOMw+bw==" src="/static/js/toast.js?v=d726c61925eee395" defer></script>
<script nonce="DLPfUwrnc73nZ87+IdF2p15xVLE=">(function(){var js = "window['__CF$cv$params']={r:'75e01acf4dd857a0',m:'OsITR3bUP4X.6lSXnB5UTXeS5NO3WUlkKnfWZ.iPJb8-1666419392-0-ASh6l/bkf2I+ZgqfiWNpxeSbqIxMmTgtNDoZZ0qgMhDc+4HkXnT2H+w7exOfEywSharutNrDWuUSg61ujYvXI0IjT9VFaP2uJdFXlK8sOLmEKR72VUJj9j8+/WV3H6hDpVztCNGY9Euk5wJR6WhXnNM=',s:[0xa0064442e6,0x7dc0b68557],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='DLPfUwrnc73nZ87+IdF2p15xVLE=',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = 'DLPfUwrnc73nZ87+IdF2p15xVLE=';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body>
</html>